diff PostgreSQL/CMakeLists.txt @ 2:17bce6a07b2b

storage plugin skeletons
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 05 Jul 2018 15:06:32 +0200
parents 7cea966b6829
children 9774802fd05f
line wrap: on
line diff
--- a/PostgreSQL/CMakeLists.txt	Wed Jul 04 18:05:24 2018 +0200
+++ b/PostgreSQL/CMakeLists.txt	Thu Jul 05 15:06:32 2018 +0200
@@ -29,6 +29,12 @@
   ${AUTOGENERATED_SOURCES}
   )
 
+add_library(OrthancPostgreSQLStorage SHARED
+  Plugins/StoragePlugin.cpp
+  ${DATABASES_SOURCES}
+  ${AUTOGENERATED_SOURCES}
+  )
+
 message("Setting the version of the libraries to ${ORTHANC_PLUGIN_VERSION}")
 
 add_definitions(
@@ -36,11 +42,11 @@
   -DHAS_ORTHANC_EXCEPTION=1
   )
 
-#set_target_properties(OrthancPostgreSQLStorage PROPERTIES 
-#  VERSION ${ORTHANC_PLUGIN_VERSION} 
-#  SOVERSION ${ORTHANC_PLUGIN_VERSION}
-#  COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=1
-#  )
+set_target_properties(OrthancPostgreSQLStorage PROPERTIES 
+  VERSION ${ORTHANC_PLUGIN_VERSION} 
+  SOVERSION ${ORTHANC_PLUGIN_VERSION}
+  COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=1
+  )
 
 set_target_properties(OrthancPostgreSQLIndex PROPERTIES 
   VERSION ${ORTHANC_PLUGIN_VERSION} 
@@ -49,7 +55,7 @@
   )
 
 install(
-  TARGETS OrthancPostgreSQLIndex  # OrthancPostgreSQLStorage  TODO
+  TARGETS OrthancPostgreSQLIndex OrthancPostgreSQLStorage
   RUNTIME DESTINATION lib    # Destination for Windows
   LIBRARY DESTINATION share/orthanc/plugins    # Destination for Linux
   )