diff CMakeLists.txt @ 14:f7379096e014

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 04 Jan 2016 14:21:51 +0100
parents 1fb480a156fd
children
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Jan 04 14:04:43 2016 +0100
+++ b/CMakeLists.txt	Mon Jan 04 14:21:51 2016 +0100
@@ -21,6 +21,7 @@
 # Some basic inclusions
 SET(ORTHANC_ROOT ${CMAKE_SOURCE_DIR}/Orthanc)
 SET(ENABLE_SSL ON)
+SET(ENABLE_PLUGINS_VERSION_SCRIPT OFF)
 
 include(CheckIncludeFiles)
 include(CheckIncludeFileCXX)
@@ -76,19 +77,20 @@
   set(ORTHANC_CPP_CLIENT_AUX ${OPENSSL_SOURCES})
 endif()
 
+add_definitions(
+  -DORTHANC_ENABLE_MD5=0
+  -DORTHANC_ENABLE_BASE64=0
+  -DORTHANC_ENABLE_LOGGING=0
+  )
 
 add_library(OrthancClient SHARED
+  Orthanc/Core/ChunkedBuffer.cpp
+  Orthanc/Core/Enumerations.cpp
   Orthanc/Core/HttpClient.cpp
-  Orthanc/Core/ImageFormats/PngReader.cpp
-  Orthanc/Core/ImageFormats/ImageAccessor.cpp
+  Orthanc/Core/Images/ImageAccessor.cpp
+  Orthanc/Core/Images/PngReader.cpp
   Orthanc/Core/MultiThreading/SharedMessageQueue.cpp
   Orthanc/Core/Toolbox.cpp
-  Orthanc/Core/ChunkedBuffer.cpp
-  Orthanc/Core/Enumerations.cpp
-  Orthanc/Core/OrthancException.cpp
-  Orthanc/Resources/ThirdParty/base64/base64.cpp
-  Orthanc/Resources/ThirdParty/base64/base64.cpp
-  Orthanc/Resources/ThirdParty/md5/md5.c
 
   CppClient/Instance.cpp
   CppClient/OrthancConnection.cpp
@@ -109,7 +111,9 @@
 add_executable(UnitTests
   CppClient/ArrayFilledByThreads.cpp
   CppClient/ThreadedCommandProcessor.cpp
+  Orthanc/Core/Enumerations.cpp
   Orthanc/Core/MultiThreading/SharedMessageQueue.cpp
+  Orthanc/Core/Toolbox.cpp
   UnitTestsSources/MultiThreadingTests.cpp
   UnitTestsSources/UnitTestsMain.cpp