diff Samples/Basic/CMakeLists.txt @ 2:8f22ed9d48d5

cont
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 01 Jun 2015 13:59:12 +0200
parents
children 6d59828e2662
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Samples/Basic/CMakeLists.txt	Mon Jun 01 13:59:12 2015 +0200
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Basic)
+
+add_executable(Test main.cpp)
+
+if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+  # Linking with "pthread" is necessary, otherwise the software crashes
+  # http://sourceware.org/bugzilla/show_bug.cgi?id=10652#c17
+  target_link_libraries(Test pthread dl)
+endif()