diff CMakeLists.txt @ 109:7381a7674b36

wip: adding labels
author Alain Mazy <am@osimis.io>
date Fri, 18 Aug 2023 12:08:49 +0200
parents 0048bde2b916
children db60c361e395
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Aug 14 10:25:40 2023 +0200
+++ b/CMakeLists.txt	Fri Aug 18 12:08:49 2023 +0200
@@ -25,8 +25,9 @@
   set(ORTHANC_FRAMEWORK_VERSION "mainline")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
 else()
-  set(ORTHANC_FRAMEWORK_VERSION "1.11.3")
-  set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
+  # TODO: switch to 1.12.2 once available
+  set(ORTHANC_FRAMEWORK_VERSION "mainline")
+  set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
 endif()
 
 # Parameters of the build
@@ -170,6 +171,8 @@
   ${PLUGIN_SOURCES}
 )
 
+DefineSourceBasenameForTarget(OrthancAuthorization)
+
 add_dependencies(OrthancAuthorization AutogeneratedTarget)
 
 message("Setting the version of the plugin to ${ORTHANC_PLUGIN_VERSION}")